aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSimon Ser <contact@emersion.fr>2023-02-18 11:05:52 +0100
committerSimon Ser <contact@emersion.fr>2023-02-19 11:02:20 +0100
commit0335ae9566310e1aa06f17a4b87d98775fd03622 (patch)
treeb8551c29daef4c3ed381a38a5caafc4dbbf554ad /meson.build
parent782b5e65655d3b8d1ecdd31c57dea342a6a0c0e0 (diff)
build: enable subproject for libxkbcommon
References: https://github.com/xkbcommon/libxkbcommon/pull/315
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 10 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index e11e52f1..ff2778ce 100644
--- a/meson.build
+++ b/meson.build
@@ -129,7 +129,16 @@ drm = dependency('libdrm',
'tests=false',
],
)
-xkbcommon = dependency('xkbcommon')
+xkbcommon = dependency(
+ 'xkbcommon',
+ fallback: 'libxkbcommon',
+ default_options: [
+ 'enable-tools=false',
+ 'enable-x11=false',
+ 'enable-docs=false',
+ 'enable-xkbregistry=false',
+ ],
+)
pixman = dependency('pixman-1',
version: '>=0.42.0',
fallback: 'pixman',