aboutsummaryrefslogtreecommitdiff
path: root/include/xwayland/meson.build
diff options
context:
space:
mode:
authorSimon Ser <contact@emersion.fr>2021-04-06 12:06:05 +0200
committerSimon Ser <contact@emersion.fr>2021-04-06 20:35:00 +0200
commit55aaeb25c57630add817524b579c3f05a805c09d (patch)
treebfd8e98dcd5743af8e10054c9f20d737157bef5a /include/xwayland/meson.build
parent672144411463e731150ab2675d4b553677fd08ec (diff)
build: use get_variable instead of get_pkgconfig_variable
This fixes the following warning: WARNING: Project targeting '>=0.56.0' but tried to use feature deprecated since '0.56.0': Dependency.get_pkgconfig_variable. use Dependency.get_variable(pkgconfig : ...) instead
Diffstat (limited to 'include/xwayland/meson.build')
-rw-r--r--include/xwayland/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/xwayland/meson.build b/include/xwayland/meson.build
index 37ddf4ca..0e26ee35 100644
--- a/include/xwayland/meson.build
+++ b/include/xwayland/meson.build
@@ -1,7 +1,7 @@
have_listenfd = false
if xwayland.found()
- xwayland_path = xwayland.get_pkgconfig_variable('xwayland')
- have_listenfd = xwayland.get_pkgconfig_variable('have_listenfd') == 'true'
+ xwayland_path = xwayland.get_variable(pkgconfig: 'xwayland')
+ have_listenfd = xwayland.get_variable(pkgconfig: 'have_listenfd') == 'true'
else
xwayland_path = xwayland_prog.full_path()
endif