aboutsummaryrefslogtreecommitdiff
path: root/include/xwayland/meson.build
diff options
context:
space:
mode:
authorSimon Ser <contact@emersion.fr>2021-10-22 14:12:49 +0200
committerSimon Ser <contact@emersion.fr>2021-11-02 12:02:51 +0100
commit3e801d68f2c6c64567b1f24c6d03893f32c81197 (patch)
tree82d983f295fc01efc776c6d250a344044d6fade2 /include/xwayland/meson.build
parent760e1665789212c49adba8d50632787f49f88c09 (diff)
xwayland: add support for -noTouchPointerEmulation
This allows compositors to handle touch pointer emulation manually, instead of having Xwayland do it [1]. [1]: https://gitlab.freedesktop.org/xorg/xserver/-/merge_requests/691
Diffstat (limited to 'include/xwayland/meson.build')
-rw-r--r--include/xwayland/meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/include/xwayland/meson.build b/include/xwayland/meson.build
index a92234f1..1dad9259 100644
--- a/include/xwayland/meson.build
+++ b/include/xwayland/meson.build
@@ -1,7 +1,11 @@
have_listenfd = false
+have_no_touch_pointer_emulation = false
if xwayland.found()
xwayland_path = xwayland.get_variable('xwayland')
- have_listenfd = xwayland.get_variable('have_listenfd') == 'true'
+ have_listenfd = xwayland.get_variable('have_listenfd',
+ default_value: 'false') == 'true'
+ have_no_touch_pointer_emulation = xwayland.get_variable(
+ 'have_no_touch_pointer_emulation', default_value: 'false') == 'true'
else
xwayland_path = xwayland_prog.full_path()
endif
@@ -9,6 +13,7 @@ endif
xwayland_config_data = configuration_data()
xwayland_config_data.set_quoted('XWAYLAND_PATH', xwayland_path)
xwayland_config_data.set10('HAVE_XWAYLAND_LISTENFD', have_listenfd)
+xwayland_config_data.set10('HAVE_XWAYLAND_NO_TOUCH_POINTER_EMULATION', have_no_touch_pointer_emulation)
configure_file(
output: 'config.h',
configuration: xwayland_config_data,