aboutsummaryrefslogtreecommitdiff
path: root/include/xwayland/meson.build
diff options
context:
space:
mode:
authorSimon Ser <contact@emersion.fr>2021-06-25 12:00:26 +0200
committerKenny Levinsen <kl@kl.wtf>2022-05-07 19:25:44 +0000
commit352064d76d459b499b39a99f889f96f40987f0e9 (patch)
tree761960b131a00d9aef86c41943e7806f1f0497cd /include/xwayland/meson.build
parent7ad67e0f1db486bf0994128f9750115722eef6d5 (diff)
xwayland: add wlr_xwayland_server_options.terminate_delay
This allows users to specify a delay after which the Xwayland process terminates itself when there are no more X11 clients connected.
Diffstat (limited to 'include/xwayland/meson.build')
-rw-r--r--include/xwayland/meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/xwayland/meson.build b/include/xwayland/meson.build
index 1dad9259..adec52fc 100644
--- a/include/xwayland/meson.build
+++ b/include/xwayland/meson.build
@@ -1,11 +1,13 @@
have_listenfd = false
have_no_touch_pointer_emulation = false
+have_terminate_delay = false
if xwayland.found()
xwayland_path = xwayland.get_variable('xwayland')
have_listenfd = xwayland.get_variable('have_listenfd',
default_value: 'false') == 'true'
have_no_touch_pointer_emulation = xwayland.get_variable(
'have_no_touch_pointer_emulation', default_value: 'false') == 'true'
+ have_terminate_delay = xwayland.get_variable(pkgconfig: 'have_terminate_delay') == 'true'
else
xwayland_path = xwayland_prog.full_path()
endif
@@ -14,6 +16,7 @@ xwayland_config_data = configuration_data()
xwayland_config_data.set_quoted('XWAYLAND_PATH', xwayland_path)
xwayland_config_data.set10('HAVE_XWAYLAND_LISTENFD', have_listenfd)
xwayland_config_data.set10('HAVE_XWAYLAND_NO_TOUCH_POINTER_EMULATION', have_no_touch_pointer_emulation)
+xwayland_config_data.set10('HAVE_XWAYLAND_TERMINATE_DELAY', have_terminate_delay)
configure_file(
output: 'config.h',
configuration: xwayland_config_data,