aboutsummaryrefslogtreecommitdiff
path: root/include/wlr/backend/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2018-08-23 20:41:07 -0400
committerGitHub <noreply@github.com>2018-08-23 20:41:07 -0400
commitdea311992eb4ff3e343c3cf5b0603034223d2a42 (patch)
tree6876337b81c01c13d53d6c4f2e3680c51fd9e204 /include/wlr/backend/meson.build
parent6db9c4b74667c1d917d720f5e96985a2461569fb (diff)
parent39ac21401fddd36474df0191603c0616d332e6da (diff)
Merge pull request #1194 from ascent12/meson_feature
Build system changes
Diffstat (limited to 'include/wlr/backend/meson.build')
-rw-r--r--include/wlr/backend/meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/include/wlr/backend/meson.build b/include/wlr/backend/meson.build
new file mode 100644
index 00000000..e005b854
--- /dev/null
+++ b/include/wlr/backend/meson.build
@@ -0,0 +1,16 @@
+install_headers(
+ 'drm.h',
+ 'headless.h',
+ 'interface.h',
+ 'libinput.h',
+ 'multi.h',
+ 'session.h',
+ 'wayland.h',
+ subdir: 'wlr/backend',
+)
+
+if conf_data.get('WLR_HAS_X11_BACKEND', false)
+ install_headers('x11.h', subdir: 'wlr/backend')
+endif
+
+subdir('session')