aboutsummaryrefslogtreecommitdiff
path: root/include/wlr/backend/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2018-08-24 08:19:10 -0400
committerGitHub <noreply@github.com>2018-08-24 08:19:10 -0400
commit8ecf9224f514e9632f51170c8de3038555e11ddf (patch)
tree03670f7af3dac95f1156d4993a39786ace175e0d /include/wlr/backend/meson.build
parent9c886f20b97b6ab1ac85b849f1fe7f16eb199ff0 (diff)
parentdc371942911aac5c098205dad7d021837d2d4acd (diff)
Merge pull request #1198 from ascent12/meson_feature
Fix meson changes
Diffstat (limited to 'include/wlr/backend/meson.build')
-rw-r--r--include/wlr/backend/meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/include/wlr/backend/meson.build b/include/wlr/backend/meson.build
new file mode 100644
index 00000000..e005b854
--- /dev/null
+++ b/include/wlr/backend/meson.build
@@ -0,0 +1,16 @@
+install_headers(
+ 'drm.h',
+ 'headless.h',
+ 'interface.h',
+ 'libinput.h',
+ 'multi.h',
+ 'session.h',
+ 'wayland.h',
+ subdir: 'wlr/backend',
+)
+
+if conf_data.get('WLR_HAS_X11_BACKEND', false)
+ install_headers('x11.h', subdir: 'wlr/backend')
+endif
+
+subdir('session')