aboutsummaryrefslogtreecommitdiff
path: root/include/wlr/backend/meson.build
diff options
context:
space:
mode:
authoremersion <contact@emersion.fr>2018-11-12 10:12:46 +0100
committeremersion <contact@emersion.fr>2018-11-12 10:12:46 +0100
commit51bfdd620e70c41e1a9fb4ce7831eddfb1bf893b (patch)
treef32586aa88e18d9bfec7cbcbeb5c682b2f35fb4a /include/wlr/backend/meson.build
parent3181c4bec06d2fe51da052c0a08c8287725ec900 (diff)
Use #if instead of #ifdef for wlroots config data
This prevents some annoying issues when e.g. not including wlr/config.h or making a typo in the guard name.
Diffstat (limited to 'include/wlr/backend/meson.build')
-rw-r--r--include/wlr/backend/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/wlr/backend/meson.build b/include/wlr/backend/meson.build
index e005b854..3d6f0e40 100644
--- a/include/wlr/backend/meson.build
+++ b/include/wlr/backend/meson.build
@@ -9,7 +9,7 @@ install_headers(
subdir: 'wlr/backend',
)
-if conf_data.get('WLR_HAS_X11_BACKEND', false)
+if conf_data.get('WLR_HAS_X11_BACKEND', 0) == 1
install_headers('x11.h', subdir: 'wlr/backend')
endif