aboutsummaryrefslogtreecommitdiff
path: root/include/wlr/backend/meson.build
diff options
context:
space:
mode:
authorScott Anderson <scott@anderso.nz>2018-08-22 21:14:07 +1200
committerScott Anderson <scott@anderso.nz>2018-08-22 21:16:16 +1200
commit51892e0d7483d57b1e5eadae88e967e72e968cc0 (patch)
treeb0775bb2146f9064a46786768cd458254561733c /include/wlr/backend/meson.build
parenta2bbf2c1f70ef374ff4a2506e65379c819b72414 (diff)
Install headers explicitly
Diffstat (limited to 'include/wlr/backend/meson.build')
-rw-r--r--include/wlr/backend/meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/include/wlr/backend/meson.build b/include/wlr/backend/meson.build
new file mode 100644
index 00000000..e005b854
--- /dev/null
+++ b/include/wlr/backend/meson.build
@@ -0,0 +1,16 @@
+install_headers(
+ 'drm.h',
+ 'headless.h',
+ 'interface.h',
+ 'libinput.h',
+ 'multi.h',
+ 'session.h',
+ 'wayland.h',
+ subdir: 'wlr/backend',
+)
+
+if conf_data.get('WLR_HAS_X11_BACKEND', false)
+ install_headers('x11.h', subdir: 'wlr/backend')
+endif
+
+subdir('session')