aboutsummaryrefslogtreecommitdiff
path: root/include/meson.build
diff options
context:
space:
mode:
authornyorain <nyorain@gmail.com>2021-02-21 18:30:12 +0100
committerSimon Ser <contact@emersion.fr>2021-10-18 11:51:13 +0200
commit8e346922508aa3eaccd6e12f2917f6574f349843 (patch)
tree550742b8a086287b6d478db1ade14b2cc4a21294 /include/meson.build
parent2edf468aeb7d4703aa211cea3b58f04cbc73298c (diff)
render/vulkan: add Vulkan renderer
This new renderer is implemented with the existing wlr_renderer API (which is known to be sub-optimal for some operations). It's not used by default, but users can opt-in by setting WLR_RENDERER=vulkan. The renderer depends on VK_EXT_image_drm_format_modifier and VK_EXT_physical_device_drm. Co-authored-by: Simon Ser <contact@emersion.fr> Co-authored-by: Jan Beich <jbeich@FreeBSD.org>
Diffstat (limited to 'include/meson.build')
-rw-r--r--include/meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/meson.build b/include/meson.build
index ff951108..3aa5955e 100644
--- a/include/meson.build
+++ b/include/meson.build
@@ -18,6 +18,9 @@ endif
if not features.get('gles2-renderer')
exclude_files += ['render/egl.h', 'render/gles2.h']
endif
+if not features.get('vulkan-renderer')
+ exclude_files += 'render/vulkan.h'
+endif
install_subdir('wlr',
install_dir: get_option('includedir'),