aboutsummaryrefslogtreecommitdiff
path: root/examples/meson.build
diff options
context:
space:
mode:
authorTony Crisci <tony@dubstepdish.com>2018-01-14 15:55:04 -0500
committerGitHub <noreply@github.com>2018-01-14 15:55:04 -0500
commite46d2dd0f884c96bb535c280a6ec9ea616d39b5c (patch)
treeaa5824b20c727291cd47e2b2962097a087b73f0b /examples/meson.build
parent66d4d2928f66bc33a8ac7c271e9ac4c992ccdd47 (diff)
parent9e85283f063d32c5e35b2091c4e67fc5cea0b630 (diff)
Merge pull request #556 from raazvvann/heghe/idle-protocol
Idle protocol
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/examples/meson.build b/examples/meson.build
index af0f5a18..aa9eac47 100644
--- a/examples/meson.build
+++ b/examples/meson.build
@@ -5,6 +5,8 @@ lib_shared = static_library(
include_directories: include_directories('support')
)
+threads = dependency('threads')
+
executable('simple', 'simple.c', dependencies: wlroots, link_with: lib_shared)
executable('pointer', 'pointer.c', dependencies: wlroots, link_with: lib_shared)
executable('touch', 'touch.c', dependencies: wlroots, link_with: lib_shared)
@@ -32,3 +34,10 @@ executable(
dependencies: [wayland_client, wlr_protos, wlroots],
link_with: lib_shared,
)
+
+executable(
+ 'idle',
+ 'idle.c',
+ dependencies: [wayland_client, wlr_protos, wlroots, threads],
+ link_with: lib_shared,
+)