aboutsummaryrefslogtreecommitdiff
path: root/examples/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2018-06-22 05:37:07 -0700
committerGitHub <noreply@github.com>2018-06-22 05:37:07 -0700
commite459fe0ec713ea65b35b966f9bb3c6c70c9504aa (patch)
treebbf22d6d1c6014d6b2174dd37c0e80c2381648b1 /examples/meson.build
parent47c7674a68ca6adfd0b8151d62c3afae32d69577 (diff)
parented7d5b0f53167b6191d408e5c7f20a3672fac3c2 (diff)
Merge pull request #992 from emersion/screencontent
Implement wlr_export_dmabuf_unstable_v1 protocol
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/examples/meson.build b/examples/meson.build
index 4725b989..939a4890 100644
--- a/examples/meson.build
+++ b/examples/meson.build
@@ -1,6 +1,10 @@
threads = dependency('threads')
wayland_cursor = dependency('wayland-cursor')
+libavutil = dependency('libavutil', required: false)
+libavcodec = dependency('libavcodec', required: false)
+libavformat = dependency('libavformat', required: false)
+
executable('simple', 'simple.c', dependencies: wlroots)
executable('pointer', 'pointer.c', dependencies: wlroots)
executable('touch', 'touch.c', 'cat.c', dependencies: wlroots)
@@ -38,3 +42,11 @@ executable(
'input-inhibitor.c',
dependencies: [wayland_cursor, wayland_client, wlr_protos, wlroots]
)
+
+if libavutil.found() and libavcodec.found() and libavformat.found()
+ executable(
+ 'dmabuf-capture',
+ 'dmabuf-capture.c',
+ dependencies: [wayland_client, wlr_protos, libavutil, libavcodec, libavformat, wlroots]
+ )
+endif