aboutsummaryrefslogtreecommitdiff
path: root/examples/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2018-03-30 17:26:58 -0400
committerDrew DeVault <sir@cmpwn.com>2018-03-30 18:23:57 -0400
commite3eb487dc2c3ed51b974212ddb15ce839289eba2 (patch)
treecac47ecb69c8bfae810360064b308e91180d7e51 /examples/meson.build
parentdc412c514b88d253dc86cf72a574530e12b7dcb7 (diff)
Add pointer support to layer shell example
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/examples/meson.build b/examples/meson.build
index 558af4ac..9e60c37a 100644
--- a/examples/meson.build
+++ b/examples/meson.build
@@ -6,6 +6,7 @@ lib_shared = static_library(
)
threads = dependency('threads')
+wayland_cursor = dependency('wayland-cursor')
executable('simple', 'simple.c', dependencies: wlroots, link_with: lib_shared)
executable('pointer', 'pointer.c', dependencies: wlroots, link_with: lib_shared)
@@ -52,5 +53,5 @@ executable(
executable(
'layer-shell',
'layer-shell.c',
- dependencies: [wayland_client, wlr_protos, wlroots]
+ dependencies: [wayland_cursor, wayland_client, wlr_protos, wlroots]
)