aboutsummaryrefslogtreecommitdiff
path: root/examples/meson.build
diff options
context:
space:
mode:
authorTimidger <APragmaticPlace@gmail.com>2018-04-16 18:42:10 -0400
committerTimidger <APragmaticPlace@gmail.com>2018-05-10 19:03:56 -0700
commitad6d40c7c6943b53285ba3f1ee58c4a0d2c00dcb (patch)
tree4f988bdc243cb2290104822c2936a2cc3dcbe7f7 /examples/meson.build
parent8fd58ce72575df0f4cd96bffe55e4eeb04227f18 (diff)
Moved cat out of support, removed support
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build32
1 files changed, 10 insertions, 22 deletions
diff --git a/examples/meson.build b/examples/meson.build
index 6b9a1f46..896f2bd0 100644
--- a/examples/meson.build
+++ b/examples/meson.build
@@ -1,53 +1,41 @@
-lib_shared = static_library(
- 'shared',
- ['support/shared.c', 'support/cat.c', 'support/ini.c', 'support/config.c'],
- dependencies: wlroots,
- include_directories: include_directories('support')
-)
-
threads = dependency('threads')
wayland_cursor = dependency('wayland-cursor')
-executable('simple', 'simple.c', dependencies: wlroots, link_with: lib_shared)
-executable('pointer', 'pointer.c', dependencies: wlroots, link_with: lib_shared)
-executable('touch', 'touch.c', dependencies: wlroots, link_with: lib_shared)
-executable('tablet', 'tablet.c', dependencies: wlroots, link_with: lib_shared)
-executable('multi-pointer', 'multi-pointer.c', dependencies: wlroots,
- link_with: lib_shared)
+executable('simple', 'simple.c', dependencies: wlroots)
+executable('pointer', 'pointer.c', dependencies: wlroots)
+executable('touch', 'touch.c', dependencies: wlroots)
+executable('tablet', 'tablet.c', dependencies: wlroots)
+executable('multi-pointer', 'multi-pointer.c', dependencies: wlroots)
executable(
'rotation',
'rotation.c',
+ 'cat.c',
dependencies: wlroots,
- link_with: lib_shared,
)
executable(
'output-layout',
'output-layout.c',
- dependencies: wlroots,
- link_with: lib_shared,
+ dependencies: wlroots
)
executable(
'screenshot',
'screenshot.c',
- dependencies: [wayland_client, wlr_protos, wlroots],
- link_with: lib_shared,
+ dependencies: [wayland_client, wlr_protos, wlroots]
)
executable(
'idle',
'idle.c',
- dependencies: [wayland_client, wlr_protos, wlroots, threads],
- link_with: lib_shared,
+ dependencies: [wayland_client, wlr_protos, wlroots, threads]
)
executable(
'idle-inhibit',
'idle-inhibit.c',
- dependencies: [wayland_client, wlr_protos, wlroots, threads],
- link_with: lib_shared,
+ dependencies: [wayland_client, wlr_protos, wlroots, threads]
)
executable(