aboutsummaryrefslogtreecommitdiff
path: root/examples/meson.build
diff options
context:
space:
mode:
authorSimon Ser <contact@emersion.fr>2020-04-21 15:19:24 +0200
committerDrew DeVault <sir@cmpwn.com>2020-04-21 15:26:45 +0200
commitab4f6421538a5fc4d539f638018aaf8b35a1f549 (patch)
tree92dd330265237d73e8775bf882af185daf9e6d46 /examples/meson.build
parent0b882475adb07cdc96fe4a585819b28b102a2b81 (diff)
build: use dicts instead of get_variable
Closes: https://github.com/swaywm/wlroots/issues/1963
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/examples/meson.build b/examples/meson.build
index 3ff27d1f..7a64da46 100644
--- a/examples/meson.build
+++ b/examples/meson.build
@@ -167,7 +167,7 @@ clients = {
foreach name, info : compositors
extra_src = []
foreach p : info.get('proto', [])
- extra_src += get_variable(p.underscorify() + '_server_h')
+ extra_src += protocols_server_header[p]
endforeach
executable(
@@ -182,8 +182,8 @@ endforeach
foreach name, info : clients
extra_src = []
foreach p : info.get('proto')
- extra_src += get_variable(p.underscorify() + '_c')
- extra_src += get_variable(p.underscorify() + '_client_h')
+ extra_src += protocols_code[p]
+ extra_src += protocols_client_header[p]
endforeach
executable(