aboutsummaryrefslogtreecommitdiff
path: root/examples/meson.build
diff options
context:
space:
mode:
authoremersion <contact@emersion.fr>2018-11-06 08:09:26 +0100
committeremersion <contact@emersion.fr>2018-11-06 08:29:30 +0100
commita8bc8c65ce63abbe15ceeaf0460b11265cdf5c29 (patch)
tree8ad9cb3f24eee5f76e06f250b9c5884e7238b5d2 /examples/meson.build
parent2d0c5ec78eb975981b1d194fa9d4bc80b894748d (diff)
examples: only link clients to wlroots if necessary
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build17
1 files changed, 8 insertions, 9 deletions
diff --git a/examples/meson.build b/examples/meson.build
index 90dbeca8..cbf39347 100644
--- a/examples/meson.build
+++ b/examples/meson.build
@@ -59,7 +59,7 @@ examples = {
},
'idle': {
'src': 'idle.c',
- 'dep': [wayland_client, wlr_protos, wlroots, threads],
+ 'dep': [wayland_client, wlr_protos, threads],
},
'idle-inhibit': {
'src': 'idle-inhibit.c',
@@ -75,7 +75,7 @@ examples = {
},
'gamma-control': {
'src': 'gamma-control.c',
- 'dep': [wayland_client, wayland_cursor, wlr_protos, wlroots],
+ 'dep': [wayland_client, wayland_cursor, wlr_protos, math],
},
'pointer-constraints': {
'src': 'pointer-constraints.c',
@@ -91,7 +91,6 @@ examples = {
threads,
wayland_client,
wlr_protos,
- wlroots,
],
},
'screencopy': {
@@ -103,13 +102,13 @@ examples = {
'dep': [wayland_client, wlr_protos, wlroots],
},
'input-method': {
- 'src': 'input-method.c',
- 'dep': [wayland_client, wlr_protos, wlroots] + libepoll,
- },
+ 'src': 'input-method.c',
+ 'dep': [wayland_client, wlr_protos] + libepoll,
+ },
'text-input': {
- 'src': 'text-input.c',
- 'dep': [wayland_cursor, wayland_client, wlr_protos, wlroots],
- },
+ 'src': 'text-input.c',
+ 'dep': [wayland_cursor, wayland_client, wlr_protos, wlroots],
+ },
}
foreach name, info : examples