aboutsummaryrefslogtreecommitdiff
path: root/examples/meson.build
diff options
context:
space:
mode:
authoremersion <contact@emersion.fr>2018-06-30 23:16:53 +0100
committeremersion <contact@emersion.fr>2018-06-30 23:18:13 +0100
commita7a96d7644ee00b29f9376576a0da8a26cf3cba6 (patch)
treee58ce0aca39c0cf8d00d2086776da2a686336d44 /examples/meson.build
parentdbb01cbcd01d191e406d99d2837c84a9d73d34a0 (diff)
examples/screencopy: use libpng
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build14
1 files changed, 9 insertions, 5 deletions
diff --git a/examples/meson.build b/examples/meson.build
index a290dc82..18f44fde 100644
--- a/examples/meson.build
+++ b/examples/meson.build
@@ -1,6 +1,8 @@
threads = dependency('threads')
wayland_cursor = dependency('wayland-cursor')
+libpng = dependency('libpng', required: false)
+
# These versions correspond to ffmpeg 4.0
libavutil = dependency('libavutil', version: '>=56.14.100', required: false)
libavcodec = dependency('libavcodec', version: '>=58.18.100', required: false)
@@ -57,8 +59,10 @@ if libavutil.found() and libavcodec.found() and libavformat.found()
)
endif
-executable(
- 'screencopy',
- 'screencopy.c',
- dependencies: [wayland_client, wlr_protos, wlroots]
-)
+if libpng.found()
+ executable(
+ 'screencopy',
+ 'screencopy.c',
+ dependencies: [wayland_client, wlr_protos, wlroots, libpng]
+ )
+endif