aboutsummaryrefslogtreecommitdiff
path: root/examples/meson.build
diff options
context:
space:
mode:
authorMarkus Ongyerth <ongy@ongy.net>2018-02-17 11:02:00 +0100
committerMarkus Ongyerth <ongy@ongy.net>2018-02-17 12:38:07 +0100
commita0bce86006788432601b60ff1cb7a373310c7253 (patch)
treecc832e54d2dc61a5a3ff9e2b53382aebd7e9cb42 /examples/meson.build
parent50d573b2ca68013a32828ae061ac2c242db333c6 (diff)
adds the client example for idle-inhibit
Adds a client example for the idle-inhibit-unsable-v1 protocol. The client creates a surface and requests an idle inhibitor. On pointer BTN_LEFT the inhibitor is destroyed if it exists, or recreated if it was destroyed before. The surfaces colour is based on the idle-inhibit state. Green if an inhibitor exists, yellow if it does not.
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/examples/meson.build b/examples/meson.build
index aa9eac47..a83def8f 100644
--- a/examples/meson.build
+++ b/examples/meson.build
@@ -41,3 +41,10 @@ executable(
dependencies: [wayland_client, wlr_protos, wlroots, threads],
link_with: lib_shared,
)
+
+executable(
+ 'idle-inhibit',
+ 'idle-inhibit.c',
+ dependencies: [wayland_client, wlr_protos, wlroots, threads],
+ link_with: lib_shared,
+)