aboutsummaryrefslogtreecommitdiff
path: root/examples/meson.build
diff options
context:
space:
mode:
authorSimon Ser <contact@emersion.fr>2019-10-08 19:33:19 +0300
committerDrew DeVault <sir@cmpwn.com>2019-10-08 12:42:18 -0400
commit9796abccedef881e99d293a2658c4da9466acd88 (patch)
treed56978995a81d311bc5cbbec933d67fc9f6abcc8 /examples/meson.build
parentb051bb68c23d8e552775494c86e5b5ad12bc7bf6 (diff)
build: workaround for meson disabler object not working with if not
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/examples/meson.build b/examples/meson.build
index 8a60e1ed..869384c2 100644
--- a/examples/meson.build
+++ b/examples/meson.build
@@ -20,7 +20,8 @@ foreach dep : ['libpng', 'libavutil', 'libavcodec', 'libavformat']
endif
endforeach
-if not cc.has_header('libavutil/hwcontext_drm.h', dependencies: libavutil)
+# Check if libavutil is found because of https://github.com/mesonbuild/meson/issues/6010
+if libavutil.found() and not cc.has_header('libavutil/hwcontext_drm.h', dependencies: libavutil)
libavutil = disabler()
endif