aboutsummaryrefslogtreecommitdiff
path: root/examples/meson.build
diff options
context:
space:
mode:
authorSimon Ser <contact@emersion.fr>2023-06-14 17:54:09 +0200
committerSimon Ser <contact@emersion.fr>2023-08-16 16:39:53 +0200
commit8836e1298859332939e9eb9bcce05272cd22ce6e (patch)
treeaf02b72188834d9fae4335b299a6efe0f3635a1c /examples/meson.build
parent8678633fc9772940a3b8b59f6caa3603a13cf5e3 (diff)
examples/embedded: new example
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/examples/meson.build b/examples/meson.build
index f0ebad64..9fee0596 100644
--- a/examples/meson.build
+++ b/examples/meson.build
@@ -223,3 +223,14 @@ foreach name, info : clients
build_by_default: get_option('examples'),
)
endforeach
+
+executable(
+ 'embedded',
+ [
+ 'embedded.c',
+ 'egl_common.c',
+ protocols_code['xdg-shell'],
+ protocols_client_header['xdg-shell'],
+ ],
+ dependencies: [wlroots, wayland_client, wayland_egl, egl, glesv2],
+)