aboutsummaryrefslogtreecommitdiff
path: root/examples/meson.build
diff options
context:
space:
mode:
authorSimon Ser <contact@emersion.fr>2021-06-22 21:05:53 +0200
committerKenny Levinsen <kl@kl.wtf>2021-06-22 21:20:20 +0200
commit8810e9508280ef4fcfd9e181f7042c8517e098b7 (patch)
tree6a02d6e66dd3b55f71d38e0d8a5438addb5ea264 /examples/meson.build
parent2f615468b68d49c8ec03ceffa751f8425d4c9b6b (diff)
Revert "build: workaround for meson disabler object not working with if not"
This reverts commit 9796abccedef881e99d293a2658c4da9466acd88. This Meson issue has been fixed upstream for a while. We require 0.56.0 so we should never hit an unpatched Meson.
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/examples/meson.build b/examples/meson.build
index 1ce02f0d..2c69fffd 100644
--- a/examples/meson.build
+++ b/examples/meson.build
@@ -18,8 +18,7 @@ else
libepoll = dependency('', required: false)
endif
-# Check if libavutil is found because of https://github.com/mesonbuild/meson/issues/6010
-if libavutil.found() and not cc.has_header('libavutil/hwcontext_drm.h', dependencies: libavutil)
+if not cc.has_header('libavutil/hwcontext_drm.h', dependencies: libavutil)
libavutil = disabler()
endif