aboutsummaryrefslogtreecommitdiff
path: root/examples/meson.build
diff options
context:
space:
mode:
authorScott Anderson <scott@anderso.nz>2018-06-26 17:22:15 +1200
committerScott Anderson <scott@anderso.nz>2018-06-26 17:25:29 +1200
commit86942d8a6aca0a56f94e1138088133ccd64701f1 (patch)
tree062f9ed1a6b821b95c736722fb05a347769b47f7 /examples/meson.build
parent4852010f296bf7fc3f291d3cec6f109308ae42fa (diff)
Check for libavutil/hwcontext_drm.h
This is an optional feature of libavutil, so this will cause a build failure if it's not present (e.g. on Debian/Ubuntu).
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/examples/meson.build b/examples/meson.build
index 04cbf744..5e5ec60a 100644
--- a/examples/meson.build
+++ b/examples/meson.build
@@ -5,6 +5,10 @@ libavutil = dependency('libavutil', required: false)
libavcodec = dependency('libavcodec', required: false)
libavformat = dependency('libavformat', required: false)
+if not cc.has_header('libavutil/hwcontext_drm.h', dependencies: libavutil)
+ libavutil = disabler()
+endif
+
executable('simple', 'simple.c', dependencies: wlroots)
executable('pointer', 'pointer.c', dependencies: wlroots)
executable('touch', 'touch.c', 'cat.c', dependencies: wlroots)