aboutsummaryrefslogtreecommitdiff
path: root/examples/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2017-07-11 20:15:28 -0400
committerGitHub <noreply@github.com>2017-07-11 20:15:28 -0400
commit85805da021006697c85489c3e30717c2b807441c (patch)
treeae4a0221b8747579314262b59ff01bec2a32d3b8 /examples/meson.build
parent8189c64d7f07a756abf5a6189719f02b2f1af967 (diff)
parente54b1eded4fc44e6f3d22af2f16d5e055dfd0045 (diff)
Merge pull request #27 from ascent12/meson
[Proposal] Use the Meson build system
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build23
1 files changed, 23 insertions, 0 deletions
diff --git a/examples/meson.build b/examples/meson.build
new file mode 100644
index 00000000..152453ae
--- /dev/null
+++ b/examples/meson.build
@@ -0,0 +1,23 @@
+lib_shared = static_library('shared',
+ ['shared.c', 'cat.c'],
+ link_with: lib_wlr,
+ dependencies: dep_wlr)
+
+all_libs = [
+ lib_shared,
+ lib_wlr,
+]
+
+executable('simple', 'simple.c', link_with: all_libs)
+executable('rotation', 'rotation.c', link_with: all_libs)
+executable('pointer', 'pointer.c', link_with: all_libs)
+executable('touch', 'touch.c', link_with: all_libs)
+executable('tablet', 'tablet.c', link_with: all_libs)
+
+compositor_src = [
+ 'compositor/main.c',
+ 'compositor/wl_compositor.c',
+ 'compositor/wl_shell.c',
+]
+
+executable('compositor', compositor_src, link_with: all_libs)