aboutsummaryrefslogtreecommitdiff
path: root/examples/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <ddevault@vistarmedia.com>2017-07-11 22:16:52 -0400
committerDrew DeVault <ddevault@vistarmedia.com>2017-07-11 22:16:52 -0400
commit7b9c330bc502f7ba4899872cc7d43de95ae5136e (patch)
treeae4a0221b8747579314262b59ff01bec2a32d3b8 /examples/meson.build
parentc81324bd0ba61ef82bc5ebd32178528c25334e69 (diff)
Revert "Fixed linking error"
This reverts commit c81324bd0ba61ef82bc5ebd32178528c25334e69.
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build24
1 files changed, 6 insertions, 18 deletions
diff --git a/examples/meson.build b/examples/meson.build
index 140fd078..152453ae 100644
--- a/examples/meson.build
+++ b/examples/meson.build
@@ -8,21 +8,11 @@ all_libs = [
lib_wlr,
]
-executable('simple', 'simple.c',
- dependencies: dep_wlr,
- link_with: all_libs)
-executable('rotation', 'rotation.c',
- dependencies: dep_wlr,
- link_with: all_libs)
-executable('pointer', 'pointer.c',
- dependencies: dep_wlr,
- link_with: all_libs)
-executable('touch', 'touch.c',
- dependencies: dep_wlr,
- link_with: all_libs)
-executable('tablet', 'tablet.c',
- dependencies: dep_wlr,
- link_with: all_libs)
+executable('simple', 'simple.c', link_with: all_libs)
+executable('rotation', 'rotation.c', link_with: all_libs)
+executable('pointer', 'pointer.c', link_with: all_libs)
+executable('touch', 'touch.c', link_with: all_libs)
+executable('tablet', 'tablet.c', link_with: all_libs)
compositor_src = [
'compositor/main.c',
@@ -30,6 +20,4 @@ compositor_src = [
'compositor/wl_shell.c',
]
-executable('compositor', compositor_src,
- dependencies: dep_wlr,
- link_with: all_libs)
+executable('compositor', compositor_src, link_with: all_libs)