aboutsummaryrefslogtreecommitdiff
path: root/examples/meson.build
diff options
context:
space:
mode:
authorRostislav Pehlivanov <atomnuker@gmail.com>2018-06-23 02:43:52 +0100
committerRostislav Pehlivanov <atomnuker@gmail.com>2018-06-25 06:41:59 +0100
commit5707653e85f2552dece8c51441a2e4ae205b5af5 (patch)
tree61f39decabd65c375f6278731207accc10d88557 /examples/meson.build
parente459fe0ec713ea65b35b966f9bb3c6c70c9504aa (diff)
examples/dmabuf-capture: move encoding to a separate thread
Drop new frames if too slow. Speeds up encoding significantly, even with vaapi.
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/examples/meson.build b/examples/meson.build
index 939a4890..04cbf744 100644
--- a/examples/meson.build
+++ b/examples/meson.build
@@ -47,6 +47,7 @@ if libavutil.found() and libavcodec.found() and libavformat.found()
executable(
'dmabuf-capture',
'dmabuf-capture.c',
- dependencies: [wayland_client, wlr_protos, libavutil, libavcodec, libavformat, wlroots]
+ dependencies: [wayland_client, wlr_protos, libavutil, libavcodec,
+ libavformat, wlroots, threads ]
)
endif