aboutsummaryrefslogtreecommitdiff
path: root/examples/meson.build
diff options
context:
space:
mode:
authorTony Crisci <tony@dubstepdish.com>2017-08-16 11:51:22 -0400
committerDrew DeVault <sir@cmpwn.com>2017-08-17 21:05:13 -0400
commit44181b57aceb2a49846d15e9cea11a704cba9786 (patch)
tree3b7959607fe5740029879369f0735049466dc118 /examples/meson.build
parent18f153810871d4d39d057bd6ceceda91c4353300 (diff)
Add wlr_output_layout implementation
An output layout consists of a mapping of outputs to their position in a global coordinate system that usually cooresponds to the output position in physical space in front of the user. Add an example that allows configuration of an output layout and demonstrates its boundaries with a bouncing image.
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/examples/meson.build b/examples/meson.build
index 1ce9c342..e2c0189c 100644
--- a/examples/meson.build
+++ b/examples/meson.build
@@ -7,6 +7,7 @@ executable('rotation', 'rotation.c', dependencies: wlroots, link_with: lib_share
executable('pointer', 'pointer.c', dependencies: wlroots, link_with: lib_shared)
executable('touch', 'touch.c', dependencies: wlroots, link_with: lib_shared)
executable('tablet', 'tablet.c', dependencies: wlroots, link_with: lib_shared)
+executable('output-layout', 'output-layout.c', dependencies: wlroots, link_with: lib_shared)
compositor_src = [
'compositor/main.c',