aboutsummaryrefslogtreecommitdiff
path: root/examples/meson.build
diff options
context:
space:
mode:
authorBrandon Dowdy <berylline@users.noreply.github.com>2021-01-28 23:13:53 +0000
committerSimon Ser <contact@emersion.fr>2021-01-29 10:03:24 +0100
commit34e7f69d6942bd37361f27c5894edc9f522d49e1 (patch)
treee1f722c0114453371711acf471afc2c38e1d2d88 /examples/meson.build
parent50b9921642af61487e2d0f425695342bf7c4ad78 (diff)
examples: remove dependency on wlr_egl from clients
The specified clients in this commit used to rely on wlr_egl and some of its related functions in order to render surfaces. This is no longer the case as of this commit.
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build16
1 files changed, 8 insertions, 8 deletions
diff --git a/examples/meson.build b/examples/meson.build
index ede85832..0300e035 100644
--- a/examples/meson.build
+++ b/examples/meson.build
@@ -54,7 +54,7 @@ clients = {
'proto': ['kde-idle'],
},
'idle-inhibit': {
- 'src': 'idle-inhibit.c',
+ 'src': ['idle-inhibit.c', 'egl_common.c'],
'dep': [wayland_egl, wlroots],
'proto': [
'idle-inhibit-unstable-v1',
@@ -62,7 +62,7 @@ clients = {
],
},
'keyboard-shortcuts-inhibit': {
- 'src': 'keyboard-shortcuts-inhibit.c',
+ 'src': ['keyboard-shortcuts-inhibit.c', 'egl_common.c'],
'dep': [wayland_egl, wayland_cursor, wlroots],
'proto': [
'keyboard-shortcuts-inhibit-unstable-v1',
@@ -70,7 +70,7 @@ clients = {
],
},
'layer-shell': {
- 'src': 'layer-shell.c',
+ 'src': ['layer-shell.c', 'egl_common.c'],
'dep': [wayland_egl, wayland_cursor, wlroots],
'proto': [
'wlr-layer-shell-unstable-v1',
@@ -78,7 +78,7 @@ clients = {
],
},
'input-inhibitor': {
- 'src': 'input-inhibitor.c',
+ 'src': ['input-inhibitor.c', 'egl_common.c'],
'dep': [wayland_egl, wayland_cursor, wlroots],
'proto': [
'wlr-input-inhibitor-unstable-v1',
@@ -96,7 +96,7 @@ clients = {
'proto': ['wlr-output-power-management-unstable-v1'],
},
'pointer-constraints': {
- 'src': 'pointer-constraints.c',
+ 'src': ['pointer-constraints.c', 'egl_common.c'],
'dep': [wayland_egl, wlroots],
'proto': [
'pointer-constraints-unstable-v1',
@@ -104,7 +104,7 @@ clients = {
],
},
'relative-pointer': {
- 'src': 'relative-pointer-unstable-v1.c',
+ 'src': ['relative-pointer-unstable-v1.c', 'egl_common.c'],
'dep': [wayland_egl, wlroots],
'proto': [
'pointer-constraints-unstable-v1',
@@ -137,7 +137,7 @@ clients = {
],
},
'toplevel-decoration': {
- 'src': 'toplevel-decoration.c',
+ 'src': ['toplevel-decoration.c', 'egl_common.c'],
'dep': [wayland_egl, wlroots],
'proto': [
'xdg-decoration-unstable-v1',
@@ -154,7 +154,7 @@ clients = {
],
},
'text-input': {
- 'src': 'text-input.c',
+ 'src': ['text-input.c', 'egl_common.c'],
'dep': [wayland_egl, wayland_cursor, wlroots],
'proto': [
'text-input-unstable-v3',