aboutsummaryrefslogtreecommitdiff
path: root/examples/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2018-11-06 12:46:29 +0100
committerGitHub <noreply@github.com>2018-11-06 12:46:29 +0100
commit2bf482e90f04dd7e402b37cb1d6c4d7fa958887c (patch)
tree8ad9cb3f24eee5f76e06f250b9c5884e7238b5d2 /examples/meson.build
parentd7b010024a4e46acb1eb5c54c1ce31dd816fb995 (diff)
parenta8bc8c65ce63abbe15ceeaf0460b11265cdf5c29 (diff)
Merge pull request #1357 from emersion/xopen-source
Use _POSIX_C_SOURCE, use shm_open
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build21
1 files changed, 10 insertions, 11 deletions
diff --git a/examples/meson.build b/examples/meson.build
index 369c7049..cbf39347 100644
--- a/examples/meson.build
+++ b/examples/meson.build
@@ -55,11 +55,11 @@ examples = {
},
'screenshot': {
'src': 'screenshot.c',
- 'dep': [wayland_client, wlr_protos, wlroots],
+ 'dep': [wayland_client, wlr_protos, rt],
},
'idle': {
'src': 'idle.c',
- 'dep': [wayland_client, wlr_protos, wlroots, threads],
+ 'dep': [wayland_client, wlr_protos, threads],
},
'idle-inhibit': {
'src': 'idle-inhibit.c',
@@ -75,7 +75,7 @@ examples = {
},
'gamma-control': {
'src': 'gamma-control.c',
- 'dep': [wayland_client, wayland_cursor, wlr_protos, wlroots],
+ 'dep': [wayland_client, wayland_cursor, wlr_protos, math],
},
'pointer-constraints': {
'src': 'pointer-constraints.c',
@@ -91,25 +91,24 @@ examples = {
threads,
wayland_client,
wlr_protos,
- wlroots,
],
},
'screencopy': {
'src': 'screencopy.c',
- 'dep': [libpng, wayland_client, wlr_protos, wlroots],
+ 'dep': [libpng, wayland_client, wlr_protos, rt],
},
'toplevel-decoration': {
'src': 'toplevel-decoration.c',
'dep': [wayland_client, wlr_protos, wlroots],
},
'input-method': {
- 'src': 'input-method.c',
- 'dep': [wayland_client, wlr_protos, wlroots] + libepoll,
- },
+ 'src': 'input-method.c',
+ 'dep': [wayland_client, wlr_protos] + libepoll,
+ },
'text-input': {
- 'src': 'text-input.c',
- 'dep': [wayland_cursor, wayland_client, wlr_protos, wlroots],
- },
+ 'src': 'text-input.c',
+ 'dep': [wayland_cursor, wayland_client, wlr_protos, wlroots],
+ },
}
foreach name, info : examples