aboutsummaryrefslogtreecommitdiff
path: root/examples/meson.build
diff options
context:
space:
mode:
authorMichael Weiser <michael.weiser@gmx.de>2020-02-14 19:26:40 +0100
committerSimon Ser <contact@emersion.fr>2020-02-20 21:40:34 +0100
commit208e6da3c3f805b5962577be804228ebbaec317b (patch)
tree129470b26c7c63f1ce5d45071546f1768fac74d1 /examples/meson.build
parent471b873de325d1bac35ab0180ee93d56336ef6a9 (diff)
keyboard-shortcuts-inhibit: Add client example
Again, copy'n'search'n'replace the idle inhibit example to become a simple keyboard shortcuts inhibit example, adding the active and inactive events. Getting the initial inhibitor needs to be done later than for idle inhibit to avoid an error "xdg_surface has never been configured". Signed-off-by: Michael Weiser <michael.weiser@gmx.de>
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/examples/meson.build b/examples/meson.build
index b7b33ff6..3ff27d1f 100644
--- a/examples/meson.build
+++ b/examples/meson.build
@@ -60,6 +60,14 @@ clients = {
'xdg-shell',
],
},
+ 'keyboard-shortcuts-inhibit': {
+ 'src': 'keyboard-shortcuts-inhibit.c',
+ 'dep': [wayland_cursor, wlroots],
+ 'proto': [
+ 'keyboard-shortcuts-inhibit-unstable-v1',
+ 'xdg-shell',
+ ],
+ },
'layer-shell': {
'src': 'layer-shell.c',
'dep': [wayland_cursor, wlroots],