aboutsummaryrefslogtreecommitdiff
path: root/examples/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2018-06-30 15:27:45 -0700
committerGitHub <noreply@github.com>2018-06-30 15:27:45 -0700
commit015ebc5750c4224d4796bba0e6deeb20c8d8a777 (patch)
tree2897ecafe78c4ca7686f63a68392aed70db40e70 /examples/meson.build
parent02dfa9101ec7fd8328ed329d2f2faa815b1ad61c (diff)
parentcc9b198f9e4e00e59773e78ab8afe1c4c0fd1ee1 (diff)
Merge pull request #1069 from emersion/screencopy
Add wlr-screencopy-unstable-v1 support
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/examples/meson.build b/examples/meson.build
index d8df0bfc..18f44fde 100644
--- a/examples/meson.build
+++ b/examples/meson.build
@@ -1,6 +1,8 @@
threads = dependency('threads')
wayland_cursor = dependency('wayland-cursor')
+libpng = dependency('libpng', required: false)
+
# These versions correspond to ffmpeg 4.0
libavutil = dependency('libavutil', version: '>=56.14.100', required: false)
libavcodec = dependency('libavcodec', version: '>=58.18.100', required: false)
@@ -56,3 +58,11 @@ if libavutil.found() and libavcodec.found() and libavformat.found()
libavformat, wlroots, threads ]
)
endif
+
+if libpng.found()
+ executable(
+ 'screencopy',
+ 'screencopy.c',
+ dependencies: [wayland_client, wlr_protos, wlroots, libpng]
+ )
+endif