aboutsummaryrefslogtreecommitdiff
path: root/example/CMakeLists.txt
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2017-06-19 15:16:40 -0400
committerGitHub <noreply@github.com>2017-06-19 15:16:40 -0400
commitfa4a04da223aadcc1feba7fe133b0f44ac01e95a (patch)
treec5b5a57ddf085993a16a5c9f29076b90f3baccf1 /example/CMakeLists.txt
parent325a331425c1771d16fa90d099fa33f3ab8772f3 (diff)
parent632a04f1b7dea35f46a2fa478bf53869854a1b5e (diff)
Merge pull request #11 from SirCmpwn/libinput
[WIP] libinput backend
Diffstat (limited to 'example/CMakeLists.txt')
-rw-r--r--example/CMakeLists.txt43
1 files changed, 43 insertions, 0 deletions
diff --git a/example/CMakeLists.txt b/example/CMakeLists.txt
index e8f7ec72..fff2e49b 100644
--- a/example/CMakeLists.txt
+++ b/example/CMakeLists.txt
@@ -1,19 +1,23 @@
include_directories(
${DRM_INCLUDE_DIRS}
${CMAKE_CURRENT_SOURCE_DIR}
+ ${XKBCOMMON_INCLUDE_DIRS}
)
add_executable(simple
simple.c
+ shared.c
)
target_link_libraries(simple
wlr-backend
wlr-session
+ ${XKBCOMMON_LIBRARIES}
)
add_executable(rotation
rotation.c
+ shared.c
cat.c
)
@@ -21,4 +25,43 @@ target_link_libraries(rotation
wlr-backend
wlr-session
wlr-render
+ ${XKBCOMMON_LIBRARIES}
+)
+
+add_executable(pointer
+ pointer.c
+ shared.c
+ cat.c
+)
+
+target_link_libraries(pointer
+ wlr-backend
+ wlr-session
+ wlr-render
+ ${XKBCOMMON_LIBRARIES}
+)
+
+add_executable(touch
+ touch.c
+ shared.c
+ cat.c
+)
+
+target_link_libraries(touch
+ wlr-backend
+ wlr-session
+ wlr-render
+ ${XKBCOMMON_LIBRARIES}
+)
+
+add_executable(tablet
+ tablet.c
+ shared.c
+)
+
+target_link_libraries(tablet
+ wlr-backend
+ wlr-session
+ wlr-render
+ ${XKBCOMMON_LIBRARIES}
)