aboutsummaryrefslogtreecommitdiff
path: root/backend/x11/meson.build
diff options
context:
space:
mode:
authoremersion <contact@emersion.fr>2018-11-13 07:53:43 +0100
committerGitHub <noreply@github.com>2018-11-13 07:53:43 +0100
commitdf7d4a71fb52d47279a93ee398220ff63d916ab7 (patch)
tree29d08a6cfdd92ed2b12ebf1139164fbb79f7ce78 /backend/x11/meson.build
parent4aff85cc8e6f90e60522a7a830424e41a6f06b77 (diff)
parentd3ee69f76bbc8b71a79840c047fa7a6144ddc628 (diff)
Merge pull request #1368 from ascent12/x11_backend
X11 backend improvements
Diffstat (limited to 'backend/x11/meson.build')
-rw-r--r--backend/x11/meson.build15
1 files changed, 3 insertions, 12 deletions
diff --git a/backend/x11/meson.build b/backend/x11/meson.build
index fa51e3d7..19e873ab 100644
--- a/backend/x11/meson.build
+++ b/backend/x11/meson.build
@@ -1,10 +1,9 @@
x11_libs = []
x11_required = [
- 'xcb',
'x11-xcb',
-]
-x11_optional = [
- 'xcb-xkb',
+ 'xcb',
+ 'xcb-xinput',
+ 'xcb-xfixes',
]
foreach lib : x11_required
@@ -16,14 +15,6 @@ foreach lib : x11_required
x11_libs += dep
endforeach
-foreach lib : x11_optional
- dep = dependency(lib, required: get_option(lib))
- if dep.found()
- x11_libs += dep
- conf_data.set10('WLR_HAS_' + lib.underscorify().to_upper(), true)
- endif
-endforeach
-
lib_wlr_backend_x11 = static_library(
'wlr_backend_x11',
files(