aboutsummaryrefslogtreecommitdiff
path: root/backend/x11/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2018-08-24 08:19:10 -0400
committerGitHub <noreply@github.com>2018-08-24 08:19:10 -0400
commit8ecf9224f514e9632f51170c8de3038555e11ddf (patch)
tree03670f7af3dac95f1156d4993a39786ace175e0d /backend/x11/meson.build
parent9c886f20b97b6ab1ac85b849f1fe7f16eb199ff0 (diff)
parentdc371942911aac5c098205dad7d021837d2d4acd (diff)
Merge pull request #1198 from ascent12/meson_feature
Fix meson changes
Diffstat (limited to 'backend/x11/meson.build')
-rw-r--r--backend/x11/meson.build44
1 files changed, 44 insertions, 0 deletions
diff --git a/backend/x11/meson.build b/backend/x11/meson.build
new file mode 100644
index 00000000..1164df1e
--- /dev/null
+++ b/backend/x11/meson.build
@@ -0,0 +1,44 @@
+x11_libs = []
+x11_required = [
+ 'xcb',
+ 'x11-xcb',
+]
+x11_optional = [
+ 'xcb-xkb',
+]
+
+foreach lib : x11_required
+ dep = dependency(lib, required: get_option('x11-backend'))
+ if not dep.found()
+ subdir_done()
+ endif
+
+ x11_libs += dep
+endforeach
+
+foreach lib : x11_optional
+ dep = dependency(lib, required: get_option(lib))
+ if dep.found()
+ x11_libs += dep
+ conf_data.set('WLR_HAS_' + lib.underscorify().to_upper(), true)
+ endif
+endforeach
+
+lib_wlr_backend_x11 = static_library(
+ 'wlr_backend_x11',
+ files(
+ 'backend.c',
+ 'input_device.c',
+ 'output.c',
+ ),
+ include_directories: wlr_inc,
+ dependencies: [
+ wayland_server,
+ pixman,
+ xkbcommon,
+ x11_libs,
+ ],
+)
+
+backend_parts += lib_wlr_backend_x11
+conf_data.set('WLR_HAS_X11_BACKEND', true)