aboutsummaryrefslogtreecommitdiff
path: root/backend/x11/meson.build
diff options
context:
space:
mode:
authorayaka <ayaka@soulik.info>2021-03-26 23:28:37 +0800
committerSimon Zeni <simon@bl4ckb0ne.ca>2021-07-22 09:56:38 -0400
commit70fb21c35ba432bec86b61ef6e938d65629fde31 (patch)
treea921aace6ca17b164d7755fd68ad9cb1f323ddc8 /backend/x11/meson.build
parent66c42f4fcb77724d9b19829eeb0c66fe4771f2db (diff)
backend: make DRM and libinput backends optional
Co-authored-by: Simon Ser <contact@emersion.fr>
Diffstat (limited to 'backend/x11/meson.build')
-rw-r--r--backend/x11/meson.build11
1 files changed, 4 insertions, 7 deletions
diff --git a/backend/x11/meson.build b/backend/x11/meson.build
index 0c6ea73b..97b6d540 100644
--- a/backend/x11/meson.build
+++ b/backend/x11/meson.build
@@ -10,17 +10,14 @@ x11_required = [
'xcb-xinput',
]
-msg = []
-if get_option('x11-backend').enabled()
- msg += 'Install "@0@" or pass "-Dx11-backend=disabled" to disable it.'
-endif
-if not get_option('x11-backend').disabled()
- msg += 'Required for X11 backend support.'
+msg = ['Required for X11 backend support.']
+if 'x11' in backends
+ msg += 'Install "@0@" or disable the X11 backend.'
endif
foreach lib : x11_required
dep = dependency(lib,
- required: get_option('x11-backend'),
+ required: 'x11' in backends,
not_found_message: '\n'.join(msg).format(lib),
)
if not dep.found()