aboutsummaryrefslogtreecommitdiff
path: root/backend/x11/meson.build
diff options
context:
space:
mode:
authorSimon Ser <contact@emersion.fr>2021-02-08 15:16:10 +0100
committerSimon Ser <contact@emersion.fr>2021-02-15 16:32:33 +0100
commit6f873078d4c0a941954be2873d3bb37f63ff31a8 (patch)
treec3148fc9ba03b6230c8241bd478748aae080b0ca /backend/x11/meson.build
parent2118a3ce47951352ee88bf475124988723d2d20a (diff)
build: use dictionnary for features instead of configuration_data
This allows us to easily iterate on all features and only deal with bools.
Diffstat (limited to 'backend/x11/meson.build')
-rw-r--r--backend/x11/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/backend/x11/meson.build b/backend/x11/meson.build
index 206e9042..6d38af19 100644
--- a/backend/x11/meson.build
+++ b/backend/x11/meson.build
@@ -35,4 +35,4 @@ wlr_files += files(
'output.c',
)
wlr_deps += x11_libs
-conf_data.set10('WLR_HAS_X11_BACKEND', true)
+features += { 'x11-backend': true }