aboutsummaryrefslogtreecommitdiff
path: root/backend/x11/meson.build
diff options
context:
space:
mode:
authorScott Anderson <scott@anderso.nz>2019-11-19 17:37:43 +1300
committerSimon Ser <contact@emersion.fr>2019-11-19 11:06:38 +0100
commit685a5a11a9f6305f7479550247b333ffdf036d73 (patch)
treedc3c7a229fa1b3478213cf8d642a7c6c1b945d00 /backend/x11/meson.build
parentfe72400bad1c8960da431ca9c8776d142f8c2f70 (diff)
backend/x11: Revert usage of present extension
This reverts commit 3317134adff0ed179e0ecaea6d778dbd0684f771. This reverts commit a3c3b928a3814f1a44babf487b1508415958c721. There are some serious issues when running this on a real X server, as opposed to running this on Xwayland, where this was tested. More investigation needs to be done into why these issues happen and if our usage of the present extension is correct.
Diffstat (limited to 'backend/x11/meson.build')
-rw-r--r--backend/x11/meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/backend/x11/meson.build b/backend/x11/meson.build
index 62b280e5..19e873ab 100644
--- a/backend/x11/meson.build
+++ b/backend/x11/meson.build
@@ -2,9 +2,8 @@ x11_libs = []
x11_required = [
'x11-xcb',
'xcb',
- 'xcb-present',
- 'xcb-xfixes',
'xcb-xinput',
+ 'xcb-xfixes',
]
foreach lib : x11_required