aboutsummaryrefslogtreecommitdiff
path: root/backend/session/meson.build
diff options
context:
space:
mode:
authorKenny Levinsen <kl@kl.wtf>2020-07-25 21:53:06 +0200
committerSimon Ser <contact@emersion.fr>2020-08-24 11:13:55 +0200
commitbad1e9afa8ea7d8927c8b4df83d3f277379dd54e (patch)
treea5f655d5b3fa824e12a1429ec4c8e49ab53f2cc9 /backend/session/meson.build
parent9feeb2738dfc5a2b07a817938cef9d553d0a26ee (diff)
session: Add libseat backend
Diffstat (limited to 'backend/session/meson.build')
-rw-r--r--backend/session/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/backend/session/meson.build b/backend/session/meson.build
index 81ff6d85..4c83685e 100644
--- a/backend/session/meson.build
+++ b/backend/session/meson.build
@@ -62,3 +62,12 @@ if logind_found
wlr_files += files('logind.c')
wlr_deps += logind
endif
+
+# libseat
+
+libseat = dependency('libseat', required: get_option('libseat'))
+if libseat.found()
+ wlr_files += files('libseat.c')
+ wlr_deps += libseat
+ conf_data.set10('WLR_HAS_LIBSEAT', true)
+endif