aboutsummaryrefslogtreecommitdiff
path: root/backend/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2019-02-22 13:58:52 -0500
committerDrew DeVault <sir@cmpwn.com>2019-04-08 08:09:07 -0600
commitfd0d7d0907fcb8783c4bd2fbbd8c8812f3ba1494 (patch)
tree003f3d8f144c92cb4073a348fd4191c96eced18d /backend/meson.build
parent9faea17c738d9bfcdd241de7bae0bbe7590c77bf (diff)
Add FreeRDP backend for remote desktop support
Diffstat (limited to 'backend/meson.build')
-rw-r--r--backend/meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/backend/meson.build b/backend/meson.build
index 67bc1874..ca85ad31 100644
--- a/backend/meson.build
+++ b/backend/meson.build
@@ -53,6 +53,22 @@ if logind.found()
backend_deps += logind
endif
+if freerdp.found() and winpr2.found()
+ backend_files += files(
+ 'rdp/backend.c',
+ 'rdp/keyboard.c',
+ 'rdp/listener.c',
+ 'rdp/output.c',
+ 'rdp/peer.c',
+ 'rdp/pointer.c',
+ )
+ backend_deps += [
+ freerdp,
+ winpr2
+ ]
+ conf_data.set10('WLR_HAS_RDP_BACKEND', true)
+endif
+
subdir('x11')
lib_wlr_backend = static_library(