aboutsummaryrefslogtreecommitdiff
path: root/backend/meson.build
diff options
context:
space:
mode:
authorSimon Ser <contact@emersion.fr>2022-11-23 16:04:43 +0100
committerSimon Zeni <simon@bl4ckb0ne.ca>2022-11-25 16:15:29 +0000
commitf0375eed24276e27e036f724c9fde5d344fc140a (patch)
tree32732996951bd290acd3ba12084ab42778134073 /backend/meson.build
parent21254737bf97e5be44071063c14fce5a403a9a22 (diff)
backend/session: make optional
Some compositors are not interested in wlr_session, for instance nested compositors. Disabling wlr_session removes the udev dependency.
Diffstat (limited to 'backend/meson.build')
-rw-r--r--backend/meson.build15
1 files changed, 10 insertions, 5 deletions
diff --git a/backend/meson.build b/backend/meson.build
index b5b6f7a6..ed977d3b 100644
--- a/backend/meson.build
+++ b/backend/meson.build
@@ -1,6 +1,3 @@
-udev = dependency('libudev')
-wlr_deps += udev
-
wlr_files += files('backend.c')
all_backends = ['drm', 'libinput', 'x11']
@@ -11,6 +8,16 @@ elif 'auto' in backends and get_option('auto_features').disabled()
backends = []
endif
+session_required = 'drm' in backends or 'libinput' in backends or get_option('session').enabled()
+if get_option('session').disabled()
+ if session_required
+ error('Session support is required for the DRM or libinput backends')
+ endif
+ session_required = disabler()
+endif
+
+subdir('session')
+
foreach backend : all_backends
if backend in backends or 'auto' in backends
subdir(backend)
@@ -20,5 +27,3 @@ endforeach
subdir('multi')
subdir('wayland')
subdir('headless')
-
-subdir('session')