aboutsummaryrefslogtreecommitdiff
path: root/backend/meson.build
diff options
context:
space:
mode:
authorMichael Weiss <dev.primeos@gmail.com>2017-12-23 22:31:31 +0100
committerMichael Weiss <dev.primeos@gmail.com>2017-12-23 22:49:41 +0100
commite457967e3f79c0d513628d7732e871c24ba6fd64 (patch)
tree40f322f5b290352be71e8cea3c1b7c4628471142 /backend/meson.build
parenteb410e0b6e8d117c12138d30542ef2f0fba5201a (diff)
Add libdrm as a dependency of wlr_backend
Without this patch I'm getting the following build error when building with Nix: FAILED: backend/wlr_backend@sta/session_direct-ipc.c.o In file included from ../backend/session/direct-ipc.c:20:0: /nix/store/9ac27wk5vh47p28gladbdfafpidrx9rh-libdrm-2.4.88-dev/include/xf86drm.h:40:17: fatal error: drm.h: No such file or directory #include <drm.h> ^ compilation terminated.
Diffstat (limited to 'backend/meson.build')
-rw-r--r--backend/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/backend/meson.build b/backend/meson.build
index 68d958a7..b8084448 100644
--- a/backend/meson.build
+++ b/backend/meson.build
@@ -45,5 +45,5 @@ lib_wlr_backend = static_library(
'wlr_backend',
backend_files,
include_directories: wlr_inc,
- dependencies: [wayland_server, egl, gbm, libinput, systemd, elogind, wlr_render, wlr_protos],
+ dependencies: [wayland_server, egl, gbm, libinput, systemd, elogind, wlr_render, wlr_protos, drm],
)