aboutsummaryrefslogtreecommitdiff
path: root/backend/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2018-08-23 21:00:58 -0400
committerDrew DeVault <sir@cmpwn.com>2018-08-23 21:00:58 -0400
commit9c886f20b97b6ab1ac85b849f1fe7f16eb199ff0 (patch)
tree7376c651ff0c75daf64bbc086858239a1d51f50b /backend/meson.build
parentdea311992eb4ff3e343c3cf5b0603034223d2a42 (diff)
Revert "Merge pull request #1194 from ascent12/meson_feature"
This breaks wlroots when used as a meson subproject. This reverts commit dea311992eb4ff3e343c3cf5b0603034223d2a42, reversing changes made to 6db9c4b74667c1d917d720f5e96985a2461569fb.
Diffstat (limited to 'backend/meson.build')
-rw-r--r--backend/meson.build20
1 files changed, 15 insertions, 5 deletions
diff --git a/backend/meson.build b/backend/meson.build
index dd1f4df3..52abe64d 100644
--- a/backend/meson.build
+++ b/backend/meson.build
@@ -1,4 +1,3 @@
-backend_parts = []
backend_files = files(
'backend.c',
'drm/atomic.c',
@@ -45,17 +44,28 @@ else
backend_files += files('session/direct.c')
endif
-if logind.found()
+if conf_data.get('WLR_HAS_SYSTEMD', false)
backend_files += files('session/logind.c')
- backend_deps += logind
+ backend_deps += systemd
endif
-subdir('x11')
+if conf_data.get('WLR_HAS_X11_BACKEND', false)
+ backend_files += files(
+ 'x11/backend.c',
+ 'x11/input_device.c',
+ 'x11/output.c',
+ )
+ backend_deps += xcb_xkb
+endif
+
+if conf_data.get('WLR_HAS_ELOGIND', false)
+ backend_files += files('session/logind.c')
+ backend_deps += elogind
+endif
lib_wlr_backend = static_library(
'wlr_backend',
backend_files,
include_directories: wlr_inc,
- link_whole: backend_parts,
dependencies: backend_deps,
)