aboutsummaryrefslogtreecommitdiff
path: root/backend/meson.build
diff options
context:
space:
mode:
authorRyan Dwyer <ryandwyer1@gmail.com>2019-01-17 20:13:55 +1000
committerRyan Dwyer <ryandwyer1@gmail.com>2019-01-17 20:13:55 +1000
commit9b4be5a59506a81175ab2eb9248f4035176df5f0 (patch)
treebde4d21776be98e7e0c51d941e9198d5d11f5c57 /backend/meson.build
parent10b1de6e718f1765f81131447d4b6b86bc78a6f4 (diff)
Introduce noop backend
The noop backend is similar to headless, but it doesn't contain a renderer. It can be used as a place to stash views for when there's no physical outputs connected.
Diffstat (limited to 'backend/meson.build')
-rw-r--r--backend/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/backend/meson.build b/backend/meson.build
index bf9b4f83..39769ecd 100644
--- a/backend/meson.build
+++ b/backend/meson.build
@@ -20,6 +20,8 @@ backend_files = files(
'libinput/tablet_tool.c',
'libinput/touch.c',
'multi/backend.c',
+ 'noop/backend.c',
+ 'noop/output.c',
'session/direct-ipc.c',
'session/session.c',
'wayland/backend.c',