aboutsummaryrefslogtreecommitdiff
path: root/backend/meson.build
diff options
context:
space:
mode:
authorScott Anderson <scott@anderso.nz>2018-08-22 19:53:00 +1200
committerScott Anderson <scott@anderso.nz>2018-08-22 19:53:00 +1200
commit94ed2fc7bbe9f673f064d3cc5e6841a3879a4268 (patch)
tree4c136aaa76cbc13d1b5edcb307c19277c61fc801 /backend/meson.build
parent3fa3dca6d583cf809a8d8d47a44ac17a5048e4e5 (diff)
Use feature options for libcap/logind
We now use a combo choice between systemd/elogind as they are mutually exclusive anyway.
Diffstat (limited to 'backend/meson.build')
-rw-r--r--backend/meson.build9
1 files changed, 2 insertions, 7 deletions
diff --git a/backend/meson.build b/backend/meson.build
index 52abe64d..48a0511a 100644
--- a/backend/meson.build
+++ b/backend/meson.build
@@ -44,9 +44,9 @@ else
backend_files += files('session/direct.c')
endif
-if conf_data.get('WLR_HAS_SYSTEMD', false)
+if logind.found()
backend_files += files('session/logind.c')
- backend_deps += systemd
+ backend_deps += logind
endif
if conf_data.get('WLR_HAS_X11_BACKEND', false)
@@ -58,11 +58,6 @@ if conf_data.get('WLR_HAS_X11_BACKEND', false)
backend_deps += xcb_xkb
endif
-if conf_data.get('WLR_HAS_ELOGIND', false)
- backend_files += files('session/logind.c')
- backend_deps += elogind
-endif
-
lib_wlr_backend = static_library(
'wlr_backend',
backend_files,