aboutsummaryrefslogtreecommitdiff
path: root/backend/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2018-02-10 09:49:13 -0500
committerGitHub <noreply@github.com>2018-02-10 09:49:13 -0500
commit8fc7edd636ce827dc147edc890e483bc3e3e9b09 (patch)
treef99478a81eeeee119a30168befaf313e604dedf2 /backend/meson.build
parent07856580c446607fa55888db8ae75491e0447c20 (diff)
parent435aec003376de1928106fa9644b026e36f6250a (diff)
Merge pull request #623 from martinetd/mesonopt
Meson option enhancements
Diffstat (limited to 'backend/meson.build')
-rw-r--r--backend/meson.build30
1 files changed, 16 insertions, 14 deletions
diff --git a/backend/meson.build b/backend/meson.build
index 9c8f5852..beb3841c 100644
--- a/backend/meson.build
+++ b/backend/meson.build
@@ -27,34 +27,36 @@ backend_files = files(
'x11/backend.c',
)
+backend_deps = [
+ wayland_server,
+ egl,
+ gbm,
+ libinput,
+ wlr_render,
+ wlr_protos,
+ drm,
+ pixman,
+]
+
if host_machine.system().startswith('freebsd')
backend_files += files('session/direct-freebsd.c')
else
backend_files += files('session/direct.c')
endif
-if systemd.found() and get_option('enable_systemd')
+if conf_data.get('WLR_HAS_SYSTEMD', false)
backend_files += files('session/logind.c')
+ backend_deps += systemd
endif
-if elogind.found() and get_option('enable_elogind')
+if conf_data.get('WLR_HAS_ELOGIND', false)
backend_files += files('session/logind.c')
+ backend_deps += elogind
endif
lib_wlr_backend = static_library(
'wlr_backend',
backend_files,
include_directories: wlr_inc,
- dependencies: [
- wayland_server,
- egl,
- gbm,
- libinput,
- systemd,
- elogind,
- wlr_render,
- wlr_protos,
- drm,
- pixman,
- ],
+ dependencies: backend_deps,
)