aboutsummaryrefslogtreecommitdiff
path: root/backend/meson.build
diff options
context:
space:
mode:
authoremersion <contact@emersion.fr>2018-04-02 15:57:04 -0400
committeremersion <contact@emersion.fr>2018-04-02 15:57:04 -0400
commit8836b4f024f957971cae28a0fdc567ff16c8fbc8 (patch)
tree23be1fc669c4fc721a521691ce182041cc7c5237 /backend/meson.build
parentcadfccf1fde164646b175401a3fb1d3108b4af9a (diff)
parentd466cc117f95d34e239049a5af701b7ba696d336 (diff)
Merge branch 'master' into xwayland-dnd
Diffstat (limited to 'backend/meson.build')
-rw-r--r--backend/meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/backend/meson.build b/backend/meson.build
index a74ea024..52abe64d 100644
--- a/backend/meson.build
+++ b/backend/meson.build
@@ -50,7 +50,12 @@ if conf_data.get('WLR_HAS_SYSTEMD', false)
endif
if conf_data.get('WLR_HAS_X11_BACKEND', false)
- backend_files += files('x11/backend.c')
+ backend_files += files(
+ 'x11/backend.c',
+ 'x11/input_device.c',
+ 'x11/output.c',
+ )
+ backend_deps += xcb_xkb
endif
if conf_data.get('WLR_HAS_ELOGIND', false)