aboutsummaryrefslogtreecommitdiff
path: root/backend/meson.build
diff options
context:
space:
mode:
authorScott Anderson <scott@anderso.nz>2018-08-22 20:27:37 +1200
committerScott Anderson <scott@anderso.nz>2018-08-22 20:27:37 +1200
commit784c20c82fb6fb84c5ce49993b5a2ec0bda13475 (patch)
treee106a1e91607f78c1fe0a7ebe5e1f3125d5ee3bb /backend/meson.build
parent94ed2fc7bbe9f673f064d3cc5e6841a3879a4268 (diff)
Use new options for X11 backend and Xwayland
Diffstat (limited to 'backend/meson.build')
-rw-r--r--backend/meson.build11
1 files changed, 3 insertions, 8 deletions
diff --git a/backend/meson.build b/backend/meson.build
index 48a0511a..dd1f4df3 100644
--- a/backend/meson.build
+++ b/backend/meson.build
@@ -1,3 +1,4 @@
+backend_parts = []
backend_files = files(
'backend.c',
'drm/atomic.c',
@@ -49,18 +50,12 @@ if logind.found()
backend_deps += logind
endif
-if conf_data.get('WLR_HAS_X11_BACKEND', false)
- backend_files += files(
- 'x11/backend.c',
- 'x11/input_device.c',
- 'x11/output.c',
- )
- backend_deps += xcb_xkb
-endif
+subdir('x11')
lib_wlr_backend = static_library(
'wlr_backend',
backend_files,
include_directories: wlr_inc,
+ link_whole: backend_parts,
dependencies: backend_deps,
)