aboutsummaryrefslogtreecommitdiff
path: root/backend/meson.build
diff options
context:
space:
mode:
authorayaka <ayaka@soulik.info>2021-03-26 23:28:37 +0800
committerSimon Zeni <simon@bl4ckb0ne.ca>2021-07-22 09:56:38 -0400
commit70fb21c35ba432bec86b61ef6e938d65629fde31 (patch)
treea921aace6ca17b164d7755fd68ad9cb1f323ddc8 /backend/meson.build
parent66c42f4fcb77724d9b19829eeb0c66fe4771f2db (diff)
backend: make DRM and libinput backends optional
Co-authored-by: Simon Ser <contact@emersion.fr>
Diffstat (limited to 'backend/meson.build')
-rw-r--r--backend/meson.build21
1 files changed, 16 insertions, 5 deletions
diff --git a/backend/meson.build b/backend/meson.build
index 3cd24b39..7fffc839 100644
--- a/backend/meson.build
+++ b/backend/meson.build
@@ -1,11 +1,22 @@
wlr_files += files('backend.c')
-subdir('drm')
-subdir('headless')
-subdir('libinput')
+all_backends = ['drm', 'libinput', 'x11']
+backends = get_option('backends')
+if 'auto' in backends and get_option('auto_features').enabled()
+ backends = all_backends
+elif 'auto' in backends and get_option('auto_features').disabled()
+ backends = []
+endif
+
+foreach backend : all_backends
+ if backend in backends or 'auto' in backends
+ subdir(backend)
+ endif
+endforeach
+
subdir('multi')
-subdir('noop')
subdir('wayland')
-subdir('x11')
+subdir('noop')
+subdir('headless')
subdir('session')