aboutsummaryrefslogtreecommitdiff
path: root/backend/meson.build
diff options
context:
space:
mode:
authorTony Crisci <tony@dubstepdish.com>2017-08-30 14:30:47 -0400
committerTony Crisci <tony@dubstepdish.com>2017-08-30 14:30:47 -0400
commit368f74e4dfab7d58293ef7d6214e6cdbe94e4fdd (patch)
tree860263145d196bd57006fec7b4dff582f74b4147 /backend/meson.build
parent6daf9e9ab2bb6e11987d3b2562fc053fd0f489c1 (diff)
Refactor meson build files
Use tabs for indentation and break up function calls over 80 col.
Diffstat (limited to 'backend/meson.build')
-rw-r--r--backend/meson.build57
1 files changed, 30 insertions, 27 deletions
diff --git a/backend/meson.build b/backend/meson.build
index fcff55b6..eb8c5d8b 100644
--- a/backend/meson.build
+++ b/backend/meson.build
@@ -1,33 +1,36 @@
backend_files = files(
- 'backend.c',
- 'session/direct-ipc.c',
- 'session/direct.c',
- 'session/session.c',
- 'drm/backend.c',
- 'drm/drm.c',
- 'drm/drm-atomic.c',
- 'drm/drm-legacy.c',
- 'drm/drm-properties.c',
- 'drm/drm-util.c',
- 'libinput/backend.c',
- 'libinput/events.c',
- 'libinput/keyboard.c',
- 'libinput/pointer.c',
- 'libinput/tablet_pad.c',
- 'libinput/tablet_tool.c',
- 'libinput/touch.c',
- 'multi/backend.c',
- 'wayland/backend.c',
- 'wayland/output.c',
- 'wayland/registry.c',
- 'wayland/wl_seat.c',
- 'wayland/os-compatibility.c',
+ 'backend.c',
+ 'session/direct-ipc.c',
+ 'session/direct.c',
+ 'session/session.c',
+ 'drm/backend.c',
+ 'drm/drm.c',
+ 'drm/drm-atomic.c',
+ 'drm/drm-legacy.c',
+ 'drm/drm-properties.c',
+ 'drm/drm-util.c',
+ 'libinput/backend.c',
+ 'libinput/events.c',
+ 'libinput/keyboard.c',
+ 'libinput/pointer.c',
+ 'libinput/tablet_pad.c',
+ 'libinput/tablet_tool.c',
+ 'libinput/touch.c',
+ 'multi/backend.c',
+ 'wayland/backend.c',
+ 'wayland/output.c',
+ 'wayland/registry.c',
+ 'wayland/wl_seat.c',
+ 'wayland/os-compatibility.c',
)
if systemd.found()
- backend_files += files('session/logind.c')
+ backend_files += files('session/logind.c')
endif
-lib_wlr_backend = static_library('wlr_backend', backend_files,
- include_directories: wlr_inc,
- dependencies: [wayland_server, egl, gbm, libinput, systemd, wlr_protos])
+lib_wlr_backend = static_library(
+ 'wlr_backend',
+ backend_files,
+ include_directories: wlr_inc,
+ dependencies: [wayland_server, egl, gbm, libinput, systemd, wlr_protos],
+)