aboutsummaryrefslogtreecommitdiff
path: root/backend/meson.build
diff options
context:
space:
mode:
authorDominique Martinet <asmadeus@codewreck.org>2018-02-10 10:04:27 +0100
committerDominique Martinet <asmadeus@codewreck.org>2018-02-10 10:44:42 +0100
commit19d7edb4301ac2c4ad3d7f7512214dad2414d64b (patch)
treee5046d42787cf135ade43b9c47c83d707e78ed1f /backend/meson.build
parent34489dca16ef9e7fd05c161b8b4f2fd5ce5e4ef0 (diff)
meson.build status: print actual build options in message
We were printing the option intent (true by default for all), but some are disabled when a component is not found and this was not reflected.
Diffstat (limited to 'backend/meson.build')
-rw-r--r--backend/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/backend/meson.build b/backend/meson.build
index 9c8f5852..e769e889 100644
--- a/backend/meson.build
+++ b/backend/meson.build
@@ -33,11 +33,11 @@ else
backend_files += files('session/direct.c')
endif
-if systemd.found() and get_option('enable_systemd')
+if conf_data.get('WLR_HAS_SYSTEMD', false)
backend_files += files('session/logind.c')
endif
-if elogind.found() and get_option('enable_elogind')
+if conf_data.get('WLR_HAS_ELOGIND', false)
backend_files += files('session/logind.c')
endif