aboutsummaryrefslogtreecommitdiff
path: root/backend/meson.build
diff options
context:
space:
mode:
authordudemanguy <random342@airmail.cc>2017-09-22 12:02:55 -0500
committerdudemanguy <random342@airmail.cc>2017-09-22 12:02:55 -0500
commit175f89f4ffdf65a53c0c55e8c3ef6256ac57b29c (patch)
treeb346254736884402a43aaffe97b7c78c7372b992 /backend/meson.build
parente5e6dab7fdbbcc5ce62a40a14b138b4e59a148d9 (diff)
Add elogind support
Resolves SirCmpwn/wlroots#146
Diffstat (limited to 'backend/meson.build')
-rw-r--r--backend/meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/backend/meson.build b/backend/meson.build
index eb8c5d8b..a3cb7b64 100644
--- a/backend/meson.build
+++ b/backend/meson.build
@@ -28,9 +28,13 @@ if systemd.found()
backend_files += files('session/logind.c')
endif
+if elogind.found()
+ backend_files += files('session/logind.c')
+endif
+
lib_wlr_backend = static_library(
'wlr_backend',
backend_files,
include_directories: wlr_inc,
- dependencies: [wayland_server, egl, gbm, libinput, systemd, wlr_protos],
+ dependencies: [wayland_server, egl, gbm, libinput, systemd, elogind, wlr_protos],
)