aboutsummaryrefslogtreecommitdiff
path: root/backend/CMakeLists.txt
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2017-04-25 15:06:58 -0400
committerDrew DeVault <sir@cmpwn.com>2017-04-25 15:06:58 -0400
commitde01e654cef2c72dce3adb580e20fe2cbc8aeb16 (patch)
tree11dbed7b9a15b1f0bb43320243c74e780e791c99 /backend/CMakeLists.txt
parent52e6ed54cbaf05cd1829099e04427d1706ca0da4 (diff)
Flesh out wayland backend somewhat, add example
Diffstat (limited to 'backend/CMakeLists.txt')
-rw-r--r--backend/CMakeLists.txt15
1 files changed, 14 insertions, 1 deletions
diff --git a/backend/CMakeLists.txt b/backend/CMakeLists.txt
index d69efdd5..01ac5e4e 100644
--- a/backend/CMakeLists.txt
+++ b/backend/CMakeLists.txt
@@ -1 +1,14 @@
-add_subdirectory(wayland)
+include_directories(
+ ${PROTOCOLS_INCLUDE_DIRS}
+ ${WAYLAND_INCLUDE_DIR}
+)
+
+add_library(wlr-backend
+ wayland/backend.c
+ wayland/registry.c
+)
+
+target_link_libraries(wlr-backend
+ wlr-common
+ ${WAYLAND_LIBRARIES}
+)